Fedora Linux Support Community & Resources Center
  #1  
Old 14th July 2013, 06:09 AM
JoshuaA Offline
Registered User
 
Join Date: Feb 2012
Location: California
Posts: 69
linuxfirefox
how to permanently disable systemd-journald.service

Systemd journal is not working right --it slows down my system, creates huge logs and I don't see any need for it. The problem is that using systemctl to disable it does not work; I disable systemd-journald.service and systemd-journald.socket, stop them and on the next boot they're running again. The logs are huge and if I don't stop the service they grow enormous.
System is fully updated fedora 19.
  #2  
Old 14th July 2013, 06:18 AM
sidebrnz Online
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 67
Posts: 2,955
linuxfirefox
Re: how to permanently disable systemd-journald.service

Simply disabling a service isn't always enough, and now, I don't know why. To tell systemd that you really don't want it starting at boot, run this as root:

systemctl mask systemd-journald.service

You should see a response telling you that the service has been linked to /dev/null, which will make sure that it doesn't start at boot until you reverse the process by using unmask instead of mask.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
  #3  
Old 14th July 2013, 07:32 AM
peoklin Offline
Registered User
 
Join Date: Oct 2010
Location: Shanghai,China
Posts: 92
windows_xp_2003ie
Re: how to permanently disable systemd-journald.service

systemctl disable systemd-journald.service
  #4  
Old 14th July 2013, 07:41 AM
sidebrnz Online
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 67
Posts: 2,955
linuxfirefox
Re: how to permanently disable systemd-journald.service

Disable should also work, but those who write the tutorials recommend using mask instead because it's guaranteed to work under all circumstances. Still, if you prefer to avoid heavy-handed solutions, you can try disable; if it doesn't stay disabled, you can always use mask.

BTW, disabling or masking a service only keeps it from starting at boot; if you want it stopped now, you need to run this as root:

systemctl stop systemd-journald.service

You should get back a message confirming that the service has, indeed, stopped.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
  #5  
Old 14th July 2013, 08:04 AM
Skull One Offline
Registered User
 
Join Date: Jun 2010
Location: Lost...
Posts: 1,300
linuxredhatmozilla
Re: how to permanently disable systemd-journald.service

Quote:
Originally Posted by JoshuaA View Post
Systemd journal is not working right --it slows down my system, creates huge logs and I don't see any need for it. The problem is that using systemctl to disable it does not work; I disable systemd-journald.service and systemd-journald.socket, stop them and on the next boot they're running again. The logs are huge and if I don't stop the service they grow enormous.
System is fully updated fedora 19.
Reminds me an old bug in the beta version (see http://forums.fedoraforum.org/showthread.php?t=291813).
If the logs grow up, it is an alert that something is wrong on the system: what are the messages logged?

Try first to stop rsyslog, it must be enough:
Code:
systemctl stop rsyslog
__________________
:confused:
  #6  
Old 14th July 2013, 01:55 PM
JoshuaA Offline
Registered User
 
Join Date: Feb 2012
Location: California
Posts: 69
linuxfirefox
Re: how to permanently disable systemd-journald.service

Thank you all for the advise I will try masking the service.

There is a bug in the kernel broadcom wireless driver that it constantly reports status --like a couple times per second. In an hour I get over 20 mb of the same message -- I don't find that useful. The system still logs information without systemd-journal, not as much information but enough.

It may take a little while before everything works right but for the most part Fedora 19 is great and runs fine on my 3 year old dell laptop.
  #7  
Old 14th July 2013, 02:09 PM
Skull One Offline
Registered User
 
Join Date: Jun 2010
Location: Lost...
Posts: 1,300
linuxredhatmozilla
Re: how to permanently disable systemd-journald.service

Which module is it? If it is b43, you can select the verbosity (look at 'modinfo b43'). Default value is 'info', but I you can set it to 'error' to not have the status messages logged.
__________________
:confused:
  #8  
Old 14th July 2013, 02:17 PM
JoshuaA Offline
Registered User
 
Join Date: Feb 2012
Location: California
Posts: 69
linuxfirefox
Re: how to permanently disable systemd-journald.service

The driver is brcmsmac --it's already in bugzilla. It's an "upstream?" bug.
  #9  
Old 14th July 2013, 02:32 PM
Skull One Offline
Registered User
 
Join Date: Jun 2010
Location: Lost...
Posts: 1,300
linuxredhatmozilla
Re: how to permanently disable systemd-journald.service

Quote:
Originally Posted by JoshuaA View Post
The driver is brcmsmac --it's already in bugzilla. It's an "upstream?" bug.
Ok. I guess there is nothing to do for this one apart disabling the logging and wait for an update...
__________________
:confused:
  #10  
Old 15th July 2013, 04:54 AM
sunveer Offline
Registered User
 
Join Date: Jun 2012
Location: New Delhi, India
Posts: 85
linuxfirefox
Re: how to permanently disable systemd-journald.service

Just rename the directory /var/log/journal to /var/log/journal.org and there will be no logging or delay afterwards.
__________________
Let's do it your way...
  #11  
Old 15th July 2013, 06:07 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 8,414
linuxfirefox
Re: how to permanently disable systemd-journald.service

The best way is to just tell systemd to limit the size of the journal, and how long to keep it, etc..

Check out the config file for it.

/etc/systemd/journald.conf
  #12  
Old 25th November 2016, 09:55 PM
iscomplicated Offline
Registered User
 
Join Date: Nov 2016
Location: Italy
Posts: 1
linuxubuntuchrome
Smile Re: how to permanently disable systemd-journald.service

Why do you want to use NSA spyware sponsored systemd and journald ?

- Binary blob that nobody looks into, good to hide information
- Touching all core commands of Linux, with lots of new interesting bugs and troians
- All major distro jump onboard for no apparent reason whatsoever
- So entangled with the whole system that it is impossible to replace

Yes, it is a NSA spyware, no doubt about it

If you are a normal person you should try your best to get rid of it... otherwise....

keep up with the cheerleading
  #13  
Old 25th November 2016, 11:28 PM
antikythera Online
Administrator
 
Join Date: Dec 2013
Location: United Kingdom
Posts: 3,615
linuxchrome
Re: how to permanently disable systemd-journald.service

Welcome to the forum,

This is a very old thread and therefore it has been closed.

ubuntu uses systemd and journald these days if you weren't already aware, NSA themselves originally developed SELinux but made it opensource. so you may want to swap to another distribution yourself containing none of these at all if concerned about such matters.

FedoraForum.org Guidelines
__________________
Download, Install and Share Fedora - Official ISO Torrents | Live ISO Respins containing post-release updates
Closed Thread

Tags
disable, permanently, systemdjournaldservice

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to permanently disable selinux wvn Guides & Solutions (Not For Questions) 25 13th February 2014 08:53 AM
How do I disable Sticky/Slow Keys permanently? omelette Using Fedora 1 30th December 2011 05:44 PM
How to disable a systemd service? Japplo F16 Development 8 5th September 2011 01:11 AM
Disable firewall permanently + SElinux on fedora core 9 bghayad Using Fedora 2 12th June 2009 03:31 AM
Disable Package Kit - PERMANENTLY Vector Using Fedora 8 9th December 2008 02:34 AM


Current GMT-time: 10:14 (Friday, 24-03-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat