Fedora Linux Support Community & Resources Center
  #1  
Old 7th July 2013, 01:19 AM
rich52 Offline
Registered User
 
Join Date: May 2009
Posts: 182
linuxchrome
KDE vs Gnome F19 (Hplip printer issues?)

I've got KDE F19 installed and ran and installed all of the Hplip files and even tested the setup and it stated all files are present and OK. . . but it still won't communicate with the printer. I installed Gnome and run the same software I installed and the printer works fine. . . What's going on here. Both KDE and Gnome are both installed on the hard drive with all of the software. In one the printer works and in the other it doesn't. . . I switch the OS shells on the fly in the boot up config menu when you log in with name and password. . .

You'd think it would work with both wouldn't you? ? ? Dunno. . . .

Rich
Reply With Quote
  #2  
Old 7th July 2013, 02:35 AM
Finalzone Offline
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,619
linuxfirefox
Re: KDE vs Gnome F19 (Hplip printer issues?)

Could you specify the model of your printer? Is it wired or wireless?
I haven't encountered an issue with my HP Photosmart eStation. The printer setup on Gnome Setting successfully detected the wireless printer and installed the driver. Only quirk is with wireless built-in scanner.
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 24 Workstation x86-64 and Windows 10 Pro 64-bit
Laptop ASUS X550ZE - APU: AMD Quad Core A10 7400P + Dual Radeon R5 230, R7 M265DX - Memory: 16GB DDR3-RAM - OS: Fedora 25 Design Suite x86-64
Reply With Quote
  #3  
Old 7th July 2013, 02:38 AM
Spaghetti Offline
Registered User
 
Join Date: Jul 2013
Location: Binghamton, NY
Posts: 24
linuxubuntufirefox
Re: KDE vs Gnome F19 (Hplip printer issues?)

Hi Rich,

my name's Rich too.

This is not a solution, but could be relevant to your situation. I have an hp 3510 printer, and distrohop too much. One thing i've learned is the only way to get my printer/scanner configured and working, regardless of distro/DE, is to use system-config-printer with a sufficient version of hplip.

reg Finalzone's scanner issue, I bet you five fake dollars that using system-config-printer to add the machine will result in a working scanner (based on my personal experience.)
Reply With Quote
  #4  
Old 7th July 2013, 02:47 AM
Finalzone Offline
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,619
linuxfirefox
Re: KDE vs Gnome F19 (Hplip printer issues?)

Yes, system-config-printer does the trick when selecting the right driver for the wireless scanner. Printer setting on Gnome Shell needs more polish there.
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 24 Workstation x86-64 and Windows 10 Pro 64-bit
Laptop ASUS X550ZE - APU: AMD Quad Core A10 7400P + Dual Radeon R5 230, R7 M265DX - Memory: 16GB DDR3-RAM - OS: Fedora 25 Design Suite x86-64
Reply With Quote
  #5  
Old 7th July 2013, 03:18 AM
rich52 Offline
Registered User
 
Join Date: May 2009
Posts: 182
linuxchrome
Re: KDE vs Gnome F19 (Hplip printer issues?)

I'm using a HP Laserjet P1006 printer which is connected via USB port.

Rich
Reply With Quote
  #6  
Old 7th July 2013, 04:45 AM
Finalzone Offline
Community Manager
 
Join Date: Mar 2004
Location: Vancouver, Canada
Posts: 2,619
linuxfirefox
Re: KDE vs Gnome F19 (Hplip printer issues?)

Thank you. You mean the issue is the printer runs fine on KDE but not on Gnome? Have you tried to add the printer in Gnome Setting? It appears to be an odd issue.
__________________
Desktop CPU: AMD Phenom II(tm) X4 Processor 940 AM2+ - Memory: 8GB DDR2-RAM - GPU: Nvidia Geforce GTX 460 v2 - OS: Fedora 24 Workstation x86-64 and Windows 10 Pro 64-bit
Laptop ASUS X550ZE - APU: AMD Quad Core A10 7400P + Dual Radeon R5 230, R7 M265DX - Memory: 16GB DDR3-RAM - OS: Fedora 25 Design Suite x86-64
Reply With Quote
  #7  
Old 7th July 2013, 04:52 AM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 6,934
linuxchrome
Re: KDE vs Gnome F19 (Hplip printer issues?)

It's the other way around, it works in Gnome and not KDE. This happens on occasion with Fedora, as it's still pretty tied in with Gnome. I do remember at one point, for example, hplip was missing a dependency that Gnome provided and the packager didn't realize it--quickly fixed, once a bug was filed.

HOWEVER--I've found that Fedora's hplip can be buggy--there have been several times where it wouldn't work for me, but installing the source from hplipopensource.com would work. (This hasn't been the case in the last few releases, however, at least for me.)

My guess is that something is missing in KDE. There's probably something in Gnome's startup scripts that is missing in KDE's startup scripts, however, not using either, I have no idea what it is. Unlike some others here, however, I've found that system-config-printer has been less reliable for me than hplip's hp-setup.
Reply With Quote
  #8  
Old 7th July 2013, 05:25 AM
rich52 Offline
Registered User
 
Join Date: May 2009
Posts: 182
linuxubuntuchrome
Re: KDE vs Gnome F19 (Hplip printer issues?)

The problem seems to me to be with KDE. As I've stated earlier my printer works fine in Gnome. I also tried the hplipopensource.com hplip file and installed it and checked all of the installed packages. It indicated everything was OK and installed properly but my printer kept giving me communication errors. (I've also resetted, unplugged the usb cable, turned off and on the printer to clear it's buffer etc. but nothing worked. So I'm now running Gnome instead of KDE on the desktop system because the printer works in Gnome. . . I can only hope it will be fixed some day in the near future. . . . just have to wait and see. . .


rich
Reply With Quote
Reply

Tags
f19, gnme, hplip, issues, kde, printer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hplip block on LPT printer bizar Using Fedora 3 16th October 2009 07:36 PM
Problem installing printer with hplip-2.8.5 charlemagneb Hardware & Laptops 0 1st June 2008 12:22 AM


Current GMT-time: 20:58 (Wednesday, 29-03-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat