Fedora Linux Support Community & Resources Center
  #1  
Old 14th February 2016, 05:41 AM
jbuckley2004 Online
Registered User
 
Join Date: Dec 2008
Location: Maryland
Posts: 430
linuxfedorafirefox
Alsamixer not remembering settings?

Due to a hard drive failure, I recently had to re-install F23, KDE spin on my desktop. In doing so I've been tripping over the same problem with Alsamixer that I had initially - I have no sound through my headphones after a reboot.

So I go to Alsamixer, use the good ol' F6 key to make sure the right sound device (the motherboard's built in sound and not the camera I have (had) mounted on my monitor), then F5 to find the sound to my headphones is muted at boot. So I un-mute it, enjoy my music, powerdown for the evening, rinse and repeat.

Originally, back in Nov. when F23 was first introduced, I noticed the same thing. But then it stopped happening (sound came up with me headphones un-muted) after, oh, about 3 days. Don't know why. Thought it might be some other update I hadn't noticed, but it was nothing intentional on my part.

But this time, after 5 days I'm still finding Alsamixer has forgotten the settings. I've always brought down Alsamixer using the escape key, so I'm I terminating it improperly? Is there some other magic incantation that I'm missing? Is it the devil-demon-dogs in my computer?

Thanks.
Reply With Quote
  #2  
Old 14th February 2016, 02:43 PM
srakitnican Online
Registered User
 
Join Date: Oct 2011
Posts: 1,221
linuxfedorafirefox
Re: Alsamixer not remembering settings?

A little quote from Ubuntu wiki:

Quote:
A caveat here: When you mute or unmute something, pulseaudio might pick it up and mute and unmute other controls, as well as PulseAudio's main mute.

If you discover that you need to do something special here to make your sound work, it is likely a bug. Please report a bug using the "ubuntu-bug audio" command. Thanks!
So your problem is probably pulseaudio not storing sound settings, you could make it work by doing hackish things like unmuting your device with a startup script, but right thing do would be to fix pulseaudio.


EDIT: Also, there is a pulseaudio confifuration file although I don't think file from post is the right file to edit becuse it will be overwritten on updates. See /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common for directives.

Last edited by srakitnican; 14th February 2016 at 03:08 PM.
Reply With Quote
  #3  
Old 14th February 2016, 03:04 PM
jbuckley2004 Online
Registered User
 
Join Date: Dec 2008
Location: Maryland
Posts: 430
linuxfedorafirefox
Re: Alsamixer not remembering settings?

Really! Yeah, because the problem seemed to "go away" on it's own, I suspect a bug somewhere. Thanks for this info., SemiRocket.
Reply With Quote
Reply

Tags
alsamixer, remembering, settings

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nautilus is not remembering settings COKEDUDE Using Fedora 5 14th September 2011 07:28 AM
xrandr - remembering settings TimIgoe Using Fedora 0 29th November 2007 12:07 PM
alsamixer default settings pmreid Using Fedora 2 22nd February 2006 12:32 AM
Remembering Sound Mixer Settings on Reboot mikecurry Using Fedora 5 7th April 2005 05:46 PM


Current GMT-time: 22:53 (Sunday, 26-03-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat